Skocz do zawartości


KOmeta
 
s-piro


Zdjęcie

forumowy projekt opensource systemu pirotechnicznego


  • Zaloguj się, aby dodać odpowiedź
587 odpowiedzi w tym temacie

#581 zk1959

zk1959

    Profi

  • Profi
  • 376 postów

Napisano 15 September 2017 12:08

Witam mam dziwny problem z jednym  z modułów knk1302  podłączając matryce 4x8 tak jak powinna być ale gdy podłączam kable do C1 i H5 to powinien odpalić kanał 5 a u mnie odpala 17 ale pierwsze 4 kanały są normalne

C1-H1 kanał 1

C1-H2 kanał 2

C1-H3 kanał 3

C1- H4 kanał 4

C1-H5 kanał  17

C4-H7 kanał 31

C4-H8 kanał 32 

Wszystko po za tymi jest jakoś pomieszane. Może ktoś na forum spotkał się z takim problemem 

 

opcji może być kilka np.

źle okablowałeś matrycę,

lub któraś dioda jest odwrotnie wlutowana, albo zwarta

 

podpinaj tylko po jednej masie C1-C4, sprawdzaj w zakresie H1-H8 jak działa, zapisuj błędy, to może coś znajdziemy



#582 Piotr1

Piotr1

    Korsarz

  • Użytkownik
  • 29 postów
  • Skąd:Ustrzyki Dolne

Napisano 15 September 2017 18:55

Witam odłączyłem matryce tak jak Pan powiedział i do zacisków C1-C4  podłączyłem - Diody 12v a do H1-H8 Plus np. kanał 1 odpowiadał kanałowi 1 na keypadzie ale kanał 5 na płytce odpowiadał kanałowi 17 na keypadzie a nie 5 
Skrót ch  odpowiada kanałowi na keypadzie 
 
Kanał   1   -1ch 
kanał   2   -2ch
kanał   3    3ch
kanał   4   -4ch
kanał   5   -17ch
kanał   6   -nie działa
kanał   7   -nie działa
kanał   8   - 20ch
kanał   9   -5ch
kanał   10  -6ch
kanał   11  -7ch
kanał   12  -8ch
kanał   13  -21ch
kanał   14  -nie działa
kanał   15  -23ch
kanał   16  -24ch
kanał   17  -9ch
kanał   18  -10ch
kanał   19  -11ch
kanał   20  -12ch
kanał   21  -25ch
kanał   22   -nie działa
kanał   23   -ch27
kanał   24   -ch28
kanał   25   -nie działa
kanał   26   -nie działa
kanał   26   -nie działa
kanał   27   - nie działa
kanał   28   -nie działa
kanał   29   -nie działa
kanał   30   -nie działa
kanał   31   -31ch
kanał   32   -32ch


#583 zk1959

zk1959

    Profi

  • Profi
  • 376 postów

Napisano 16 September 2017 09:26

Ponieważ w tych testach widać jednak pewną logikę to zacząłem szukać ewentualnej przyczyny błędów.

No i okazało się, że schemat

http://www.pyrobox.c...ch_2_130730.pdf

a konkretnie wyjścia modułu, zostały przeze mnie błędnie opisane,

czego przez te kilka lat zarówno ja, jak i nikt inny nie zauważył, a przynajmniej nie zgłosił.

Nie pamiętam, ale może to wynik kolejnych zmian robionych w oprogramowaniu FSpro i ATmega.

Powinno być tak

http://www.pyrobox.c...ch_2_170916.pdf

czyli wyjścia podzielone są na dwie sekcje, tak jak to widać w FSpro,

tzn. że są jakby dwie matryce, C1/C2/C3/C4 + H1/H2/H3/H4 oraz C1/C2/C3/C4 + H5/H6/H7/H8

Zrób jeszcze raz test przy takim opisie i podaj wynik.



#584 Piotr1

Piotr1

    Korsarz

  • Użytkownik
  • 29 postów
  • Skąd:Ustrzyki Dolne

Napisano 16 September 2017 17:29

Witam teraz po próbach w kombinacjach C1/C2/C3/C4 + H1/H2/H3/H4 oraz C1/C2/C3/C4 + H5/H6/H7/H8 wszystko działa i jest zgodne z matrycami i na keypadzie.  :D 

Nie ma żadnych błędów więc jak znajdzie Pan czas na stronie KNK1301 można zmienić opis dla następnych pokoleń żeby już było wszystko porządku.

Pozdrawiam i dziękuje za szybką odpowiedz z Pana strony



#585 avula

avula

    Achtung

  • Użytkownik
  • 48 postów

Napisano 17 September 2017 08:46

Super Avula !

Kawał dobrej roboty !

 

Zamieniłem pliki sch i brd na pdf

http://pyrobox.com.p...3_avula_sch.pdf

http://pyrobox.com.p...3_avula_brd.pdf

Wszystkim będzie łatwiej podziwiać Twoją pracę :)

 

Widzę, że port PA6 jest wolny.

Może dorobimy pomiar napięcia akumulatora?

Mógłby się pokazywać na LCD przy włączaniu modułu.

 

Pozdrawiam.

Zdravím.
Bylo by to dobré zjistit napětí akumulátoru, bez další montáže dodatečného voltmetru. Jak se to dá realizovat.

 

Witam.
Dobrze byłoby sprawdzić napięcie akumulatora bez instalowania dodatkowego woltomierza. Jak to zrobić.



#586 zk1959

zk1959

    Profi

  • Profi
  • 376 postów

Napisano 17 September 2017 14:46

Do pomiaru napięcia akumulatora z pomocą ATmega potrzeba niewiele,

wystarczy pomiędzy zacisku akumulatora wpiąć taki prosty układ

i podłączyć go do portu PA6 ATmega.

(100K i 180K to rezystory, a R10K potencjometr montażowy)

                               

AKU12V <--[100K]--+--[R10K]--[180K]--> AKU+12V

                                |

                     ATmega PA.6

 

No i oczywiście wgrać nowy HEX do ATmega

http://www.pyrobox.c...L48A-104-16.zip

 

Potencjometrem montażowym 10K trzeba skorygować

wynik pomiaru jaki wyświetli się na LCD

porównując go z pomiarem napięcia akumulatora zwykłym woltomierzem.



#587 avula

avula

    Achtung

  • Użytkownik
  • 48 postów

Napisano 17 September 2017 20:11



Do pomiaru napięcia akumulatora z pomocą ATmega potrzeba niewiele,

wystarczy pomiędzy zacisku akumulatora wpiąć taki prosty układ

i podłączyć go do portu PA6 ATmega.

(100K i 180K to rezystory, a R10K potencjometr montażowy)

                               

AKU12V <--[100K]--+--[R10K]--[180K]--> AKU+12V

                                |

                     ATmega PA.6

 

No i oczywiście wgrać nowy HEX do ATmega

http://www.pyrobox.c...L48A-104-16.zip

 

Potencjometrem montażowym 10K trzeba skorygować

wynik pomiaru jaki wyświetli się na LCD

porównując go z pomiarem napięcia akumulatora zwykłym woltomierzem.

myslel jste to takto?

 

Czy to miałeś na myśli?

 

Skener_20170917.jpg



#588 zk1959

zk1959

    Profi

  • Profi
  • 376 postów

Napisano 17 September 2017 20:47

Tak, tylko podepnij to za włącznikiem zasilania,

bo inaczej akumulator będzie się wolno rozładowywał.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych